Out with the Old

Java 6 was released in 2006. It is now 2015. It has been 9 years since the release of Java 6. Therefore, I feel it's time to bump the version I compile my software against.

Let's look at Java 7. Java 7 was released in 2011 and has since been succeeded by Java 8. It will reach its end-of-life after April of this year, which is exactly when I intend to switch to using it as a standard. It's a little backwards, but there's not really much more I can do while Java 8 has less than a 50% market share.

So in summary: starting in May, all future releases of my software, plugins, games, whatever, will be compiled against Java 7, dropping support for 6. It's not an easy choice, but I feel it's necessary, and I'd like to begin using features introduced to the language more recently. That being said, I offer my apologies to those that are affected by this.

Posted by Max Roncace on February 13, 2015

Log in or register to post a comment!

No comments to display!